pity-riotous
pity-riotous
pity-riotous
pity-riotous
hyenas
hyenas
hyenas
hyenas
Linux on your Apple Mac | iLinux • View topic - Installation freeze on PowerMac G4 Debian

Installation freeze on PowerMac G4 Debian

Installation freeze on PowerMac G4 Debian

Postby linuxopjemac » Thu Nov 25, 2010 10:56 am

Hi,
Im trying to install the latest version of debian (donwloaded today) on my old powermac G4 (Quicksilver 867mhz, 512mb ram) but the installation is randomly freezing (the computer stops responding and finally reboot).
I've tried to reset the p-ram and v-ram, I also tried to install freebsd but the installer is freezing too.
I don't have a clue of what my problem may be.
I don't have the latest version available of OpenFirmware, maybe this is why the installation is freezing ?
However I didn't have any problem with osx (10.5 leopard).
If someone can help me I will be very grateful ;)
Thanks by advance
(Please excuse my bad English which is'nt my 1st language)

I tried every current debian version available and it's not working.
I noticed that the installation is freezing when the installer try to load partman or to create the partition (in squeeze) maybe there is a problem with the hard drive ? But I have the same problem if I connect an other hard drive.

Solution:
Well, guess what, I just happen to have tried an install of Debain 5.0.6 for PowerPCs via netboot also and ran into what sounds like the same problem.

Someone in the area was moving out and was going to through away into bulk garbage an old iMac G3 --- so, having been defeated one before by one of these Spawn of Satan computers I couldn't resist giving it a try to repair (agian one that was being thrown away some years ago, but in that case it was because they finally recognized what garbage Apple PCs are vs comparably priced Intel based PCs with Windows --- sorry if the offends some of you).

I first used my old OS9.x software to check it out and everything tested OK (RAM, hard drive, etc... of course I got a message that the Firmware needed to be updated -- I didn't bother to update as it was not needed to install Linux for PPCs).

I did mange to get Xubuntu 9.10, and a few others installed on that old iMac G3 (e.g. CRUX 2.6 but had to use Xubuntu 9.10 kernel and modules) --- runs farily well (160MB RAM helps). Next I thought I'd play around with the ethernet boot process of Debain 5.0.6 for the PPCs --- again, being just a glutton for punishment.

I ran into what sounds like the same type problems as were described by other posters. But I did find the solution (at least for me). The netboot initrd for the PPC was defectived! It didn't have all the kernel modules in it, in particular, it didn't have the ide modules (e.g. ide-disk.ko). I managed to track this down by comparing the netboot initrd to the cdinstall initrd. Once I put all the kernel drivers found in the cdinstall initrd into the netboot intrd, everything proceeded forward where it was previously stopping. I assume you know how to unpack and rebuild initial ram drives (they are just gzipped cpio archieves).

That's my experience, hope it helps some.

Reference:
http://forums.debian.net/viewtopic.php? ... 50#p334250
linuxopjemac
Site Admin
 
Posts: 541
Joined: Tue Feb 02, 2010 8:48 am

Return to Installation

Who is online

Users browsing this forum: Bing [Bot] and 0 guests

cron
pity-riotous
pity-riotous
pity-riotous
pity-riotous
hyenas
hyenas
hyenas
hyenas